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INTRODUCTION
This is a basic introduction to the Excel features frequently used by CUNY data staff. This guide
assumes basic familiarity with Excel (there are good tutorials on the Microsoft website to help
you get started).

USEFUL FUNCTIONS
Function

Excel Formula

Addition

=SUM(number1, number2, …) or
=number1 + number2 + …

Multiplication

=PRODUCT(number1, number2, …) or
=number1*number2*…

Average

=AVERAGE(number1, number2, …)

Median

=MEDIAN(number1, number2, …)

Maximum

=MAX(number1, number2, …)

Logical Test

=IF(logical_test,[value _if_true],[value_if_false])

Join Mult. Strings into One

=CONCATENATE(text1, text2, …)

Select Char(s) from String

=MID(text, start_num, num_chars)

Convert Char String to #

=VALUE(text)

Convert Char to UPPERCASE

=UPPER(text)

Count # Empty Cells

=COUNTBLANK(range)

Count # Cells Meeting Condition

=COUNTIF(range, criteria)

Current Date

=TODAY()

GETTING STARTED WITH FORMULAS
You may either type numbers directly into a formula or link a formula to numbers in other cells.
For example, to find the sum of the numbers 2, 3, and 4, you can simply type =SUM(2,3,4) in any
cell and hit enter. Alternatively, you can use a link formula by entering the numbers 2, 3, and 4
into any three cells, typing =SUM( in a forth cell, and then dragging the cursor over the cells
containing the numbers and hitting enter.
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When working with even basic data sets, budgets, or tables, use Excel formulas (and particularly
linked formulas) as much as possible. Never do a calculation by hand and then type the solution
into Excel. There are three main reasons for this recommendation:
 First, your calculations are subject to human error.
 Second, formulas serve as a road map of all of your assumptions and
calculations, which comes in handy both as a reminder to yourself and for
sharing files with other people.
 Third, working with Excel worksheets often requires revisions as estimates or
decision rules change over time. Using linked formulas makes revisions easier.

NESTED FORMULAS
It is possible to nest multiple IF functions within one Excel formula. You can nest up to seven IF
functions to create a complex IF THEN ELSE statement. The syntax for the nesting the IF
function is:
=IF( condition1, value_if_true1, IF( condition2, value_if_true2, value_if_false2 ))
condition is the value that you want to test
value_if_true is the value that is returned if condition evaluates to TRUE
value_if_false is the value that is return if condition evaluates to FALSE
Example 1: In Excel, you need to write a formula that works this way:
If (cell A1) is less than 20, then multiply it by 1,
If it is greater than or equal to 20 but less than 50, then multiply it by 2
If it is greater than or equal to 50 and less than 100, then multiply it by 3
And if it is great or equal to than 100, then multiply it by 4
You can write a nested IF statement to handle this. For example:
=IF(A1<20, A1*1, IF(A1<50, A1*2, IF(A1<100, A1*3, A1*4)))
Example 2: In Excel, you need a formula in cell C5 that does the following:
IF A1+B1 <= 4, return $20
IF A1+B1 > 4 but <= 9, return $35
IF A1+B1 > 9 but <= 14, return $50
IF A1+B1 > 15, return $75
In cell C5, you can write a nested IF statement that uses the AND function as follows:
=IF((A1+B1)<=4,20,IF(AND((A1+B1)>4,(A1+B1)<=9),35,IF(AND((A1+B1)>9,(A1+B1)<=14),50,75)))
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COPYING AND PASTING FORMULAS
Copying and pasting formulas can save a lot of time. For example, if you need to calculate the
average exam score for students taking four exams (assume one column of score data for each
exam type), you can first set up the sum formula for the first exam type column and simply copy
and paste the formula into the columns for the second, third, and fourth exam types.
This works because Excel’s default option is “relative cell references,” which means that when
you copy and paste a formula into a new cell, the cell references in the formula move a
corresponding number of cells across and down. For example, suppose you create a formula in
cell C3 that divides the value in cell A3 by the value in cell B3; the formula in cell C3 would be
=A3/B3. If you copy and paste the formula into the next cell to the right (D3), the formula will
automatically shift the references one cell to the right, to become =B3/C3. Similarly, if you copy
and past this formula in the next cell down (C4), the formula will automatically shift the
references one cell down, to become =A4/B4.
But what if you want to keep the numerator or denominator constant? For example, suppose
you want to divide each of the values in cells A3 through A10 by the value in cell B3. You could
enter those formulas one at a time, but there is an easier way: you can tell Excel not to
automatically adjust some or all of the cell references in the formula. All you have to do is place
a dollar sign ($) in front of the column letter or row number you want to remain fixed. In this
case, the formula in C3 should be =A3/B$3. This is known as an “absolute cell reference.” When
you copy and past this formula into cells C4 through C10, the numerator will change but the
denominator will remain B3. If you want to keep the column fixed as well – for example, so that
the formula can be copied into a cell in column D without changing the denominator—then put
a dollar sign in front of the column letter as well: =A3/$B$3. A shortcut is to highlight the
formula and use the F4 key as a toggle.

GETTING THE MOST OUT OF FORMULAS
Adding Hidden Text to Formulas:
Imagine you have a formula like: =$2018+$1056‐4*$120. When you initially wrote it you knew
what each number represented, but you come back later and can't remember. Add a hidden
note to your formula by using the N() formula i.e. =$2018+$1056‐4*$120+N("My Wage+Bonus‐4
weekly loan repayments"). The N() function will convert text to zero.
Adding Text to Formulas:
To show a formula result and text or number(s) in the same cell type a & (Ampersand) after the
formula then your text/number(s).
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See Formula Cells:
If you have a sheet full of formulas and you want to identify these cells at a glance go to Edit>Go
to>Special and select "Formulas" then click "OK". Now go to Format>Cells or Ctrl+1 and select
the "Patterns" tab and choose a color.
Showing Formulas:
Occasionally you will need to show the Excel formula you used as text. To display a formula,
simply put an apostrophe in front of the formula. For example: ‘=SUM(3,24,100).
Formula Errors:
Whenever typing one of Excel’s functions (especially nested ones) into a cell always use lower
case. This way when you push Enter Excel will capitalize only the names of the functions you
have entered correctly.

FORMATTING AND THE F4 KEY
Changing the format of a cell (dollar signs, decimal places, negative numbers, etc.):
To change the format of a cell, select the cell, go to the Format menu, and click Cells. On the
Number tab, choose the desired format type and then, if you are working with a number, select
the desired number of decimal places. The F4 key (which repeats the previous operation) can
be used to repeat the format changes for multiple cells.
Making Columns wider:
If a column is too narrow to show the entire contents of the cell, ##### will appear in the cell. To
increase the column width, go to the Format menu and click Column and then Autofit (or, for a
custom width, choose Width and then select a larger number). Alternatively, you can just drag
the right edge of the column header to the right. Similarly, make rows taller by going to Format
menu and selecting Rows instead of Columns, or drag the bottom edge of the row header down.
Merging Cells (e.g., center a heading over a table or create a large text box):
Select the cells you want to merge, go to the Format menu, and click Cells. On the Alignment
tab, click the box called Merge Cells. If you are centering a heading, choose Horizontal
Alignment: Center. (Or as a shortcut, you can use the “Merge and Center” button on the
toolbar; it looks like the letter “a” with arrows on either side). If you are creating a text box and
you want the text to “wrap around” to the next row of the cell, select Wrap Text (in this case
you might also want to select Horizontal Alignment: Top). If you want a border around the
merged cells, go to the Border tab and choose Outline.
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Making a large table fit onto a single page:
Go to the File menu, select Page Setup, and select “Fit to 1 page(s) wide by 1 tall.” For wide
tables, choose the Landscape setting; for tall tables, choose the Portrait setting. Before printing,
always use Print Preview to make sure that your table does not span multiple pages or comes
out so small that it is illegible.
Controlling your view of the data:
Freeze Panes is a useful feature when you are working with a large document that has many
rows. By freezing a certain row (usually the header), you make that row visible wherever you
are in the document. For example, if you have a document with 100 rows, you can't see the
header row when you're at cell A100. To solve that problem, click on the row below the one that
you would like to freeze. To freeze the header row, click on the cell in the second row and first
column. Then go to Window > Freeze Panes. [It's important to note you can freeze columns as
well as rows. If you just click at an arbitrary point in the second row, not only will you freeze the
top row, you'll also freeze all columns to the left of the cell you've selected.]

SORTING AND FILTERING DATA
You can order your data from the Sort window in ascending or descending order as well as
based on multiple header values. Sorting data is simply a way of automatically re‐ordering rows
on a spreadsheet to put them in a more useful order. For instance, you might sort an address
book alphabetically by last name, or a list of items you'd like to buy from most expensive to least
expensive.
Start by selecting the data you want to sort. It's important to select all the columns in the data,
not just the column you want to sort by. For instance, if you have a list of items in one column,
with the prices in the next column, you would select both columns before running the sort. If
your sheet has a "header row" at the top with labels for your columns (like "name," or "price")
it's a good idea to include that row in your selection as well, as you'll see in a moment.
Once you have your data selected, click Data > Sort. If your data has a header row, be sure the
"header row" bubble is filled in at the bottom. Excel will then use your labels in the "Sort by"
boxes instead of the usual (unhelpful) "Column A," "Column B," etc. Now you can use the "Sort
by" box to select the column you'd like to sort the data by (if that column contains text, it will
sort alphabetically; if the data is numeric it is sorted in number order). The two "Then by" boxes
select what column to use next if there is a tie in the "Sort by" column.
Another way to organize data is to filter it. A filter only displays data that meet a certain criteria,
such as all records for a certain day. To do this, go to Data > Filter > AutoFilter. A dropdown
arrow will appear in the header cell of each column of your worksheet. Click on the arrow and
select the criteria that you would like to use as a filter (e.g. April 10th). The worksheet will now
display only the records from that day. You can also use the AutoFilter tool to display the top or
bottom 10 numbers in a column, only records with blank spaces in that particular column,
records that have a value greater than a certain number in the column that you are filtering, etc.
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NAMED RANGES
To name a selected range, click in the “Name box” (far left on the formula bar) and type a one
word name.
To go to an existing named range select it from the “Name box” or hit F5.
To delete or edit a named range go to Insert > Name > Define or Push CTRL + F3.
To obtain a list of all Named Ranges and where they refer, select any blank cell (make sure you
have not data underneath or 1 column over) and go to Insert > Name > Paste then Paste List.

DATES AND TIMES
To insert today’s date: CTRL + ; (semicolon)
To insert the current time: CTRL + SHIFT + : (colon)

DATA ANALYSIS TOOLPAK
Microsoft Excel provides a set of data analysis tools, called the Analysis ToolPak that you can use
to save steps when you develop complex statistical analyses. Excel can even do regressions.
Data Analysis will bring up a dialog box where you can choose the type of analysis (regression,
histogram, ...) and then choose which cells contain your X or Y data.
Click Tools  Data Analysis Descriptive Statistics
If Data Analysis doesn't show up as an option in your Tools menu, add it by going to Tools 
Add‐Ins and checking the Analysis Toolpak.

TEXT TO COLUMNS
Text to Columns (located in the Data menu) is a useful tool for separating into multiple columns
text that is currently contained in one column. For example, maybe you have social security
numbers in column A and you just need the last four digits of the SSN. Text to Columns would
let you separate the SSN into two columns.

OTHER TIPS AND SHORTCUTS


When working with multiple worksheets, move one worksheet to the right by pressing
CTRL + PAGE DOWN
To move one worksheet to the left, press
CTRL+ PAGE UP
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To insert a line break in a cell, press
ALT + ENTER to start a new line while you’re typing or editing data.



To move or copy a worksheet
Right‐click a tab, and then click Move or Copy on the shortcut menu.
In the Move or Copy dialog box, you can:
 Move the worksheet to a spot within its own workbook by selecting a sheet
in the Before sheet box.
 Move the worksheet to another open workbook by selecting the workbook
in the To book list and then click OK.
 Keep a copy of the worksheet you’re moving in this workbook (rather than
just moving it), select the Create a copy box.



When you've imported data sometimes numbers will come in as text. That is, they look
like numbers but don't act like numbers. A quick way to identify this problem is to use
the Excel feature that when a block of cells is selected the SUM of the cells will appear in
the Status Bar. Numbers that are text will have a value of zero in the SUM. To convert
text to numbers:
Select the cells to convert
 Right‐click in the upper left‐hand corner of a block of blank cells large
enough to accommodate the cells you want to convert
 Choose Paste Special
 In the Paste Special dialog box choose the Operation, Add
Doing this arithmetic operation of adding the cells' text value with the zero value of the
destination cells forces Excel to convert the text value to a number.

TROUBLESHOOTING
Common sources of errors are parentheses that don't match or missing arguments for functions.
If your formula is free from those errors, here are some error values you might get:
######

There is nothing wrong with your formula; the cell simply isn't big enough to
display the result. Widen the column.

#DIV/0

You are trying to divide by zero; correct the divisor. If the divisor is a cell
reference, check to make sure the cell isn't empty.

#NAME?

There is a name in the formula that Excel doesn't recognize. If you typed in a
function, check the spelling or verify that the function exists. If you are
performing operations on text, enclose the text in double quotation marks.
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#REF!

A cell reference is not valid. Reenter the formula.

#VALUE!

The formula uses the wrong type of operand or argument. Check to see that
you're not performing math operations on labels or that arguments of functions
that need to numeric are not referring to cells containing labels.

EXCEL CHARTS AND GRAPHICS
A chart often makes it easier to understand the data in a worksheet because users can easily
pick out patterns and trends illustrated in the chart that are otherwise difficult to see.
A full discussion of Excel's many charting options is beyond the scope of this handout. However,
it is fairly straightforward to create a simple chart (and some complicated ones) using the chart
wizard. Just highlight the data you wish to base your chart on (including header rows, if you
have any) and click the chart wizard button on the toolbar. The chart wizard will then take you
through four steps:
1. Selecting the type of chart you want
2. Verifying the data range you selected
3. Setting options for labels, axes, legends, etc.
4. Choosing whether you'd like the chart to appear in the current working sheet, or in its
own, new sheet.
A help button is available at each step in the wizard if you're confused by any option. A quick
way to get a chart started is to select the data and headers you wish to chart, and press F11 on
your keyboard.
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